Logging Messages

Error and warning logging messages

The following table includes descriptions and resolutions for error and warning log messages.

Message ID

Type

Description

Resolution

10901

Error

The data feed is configured to run an Archer Web Service (AWS) Transporter. This transporter uses the Archer web service to obtain the source content. The data feed has indicated that Internet Information Services (IIS) is set either to allow anonymous access or allow the same account used by the job service to access the Archer web service. However, the data feed is unable to authenticate to the web services using this access. You can find additional information on AWS Security by visiting the Archer Community on Archer Community at:

https://www.archerirm.community/

Possible cause:

The authentication information is specified in the Security section of the Transport tab. This information must match the way in which the authentication is set up for the Archer web service in IIS. It is important to notice this distinction because the authentication is defined within IIS and not within the Data Feed Manager. The Data Feed Manager needs to identify the manner in which the authentication is set up within IIS.

The data feed is configured to either access the IIS Archer web services through Anonymous Authentication or Windows Authentication with the Log On user specified for the Archer Job Engine service.

Ensure that IIS is set up to allow 1 of these methods of authentication for the “ws” folder within the Archer web site. If IIS is not set up to allow 1 of these types of authentication, then either the authentication method needs to be changed in IIS, or the data feed Security configuration needs to be changed to match the IIS authentication method.

10902

Error

The data feed is configured to run an Archer Web Services Transporter. The data feed is set up to indicate that Windows Authentication is required to gain access to IIS, but there is a problem using this access. You can find additional information on AWS Security by visiting the Archer Community on Archer Community at:

https://www.archerirm.community/

Possible cause:

The authentication information is specified in the Security section of the Transport tab. This information must match the way in which the authentication is set up for the Archer Web Service in IIS. It is important to notice this distinction because the authentication is defined within IIS. not within the Data Feed Manager. The Data Feed Manager needs to identify the manner in which the authentication is set up within IIS.

The data feed is configured to access the IIS Archer web services via Windows Authentication. A specific user is specified in the Security tab.

Ensure that the user name, password and domain are entered correctly and that this user has access to the IIS web service folder (“ws”).

10903

Error

Unable to authenticate to the source instance of Archer. The source instance is identified by the URL specified in the Security section of the Transport tab. The user name, password and domain are specified in the Transport Configuration section in the Transport tab.

Possible cause:

The data feed is not able to authenticate to the instance of Archer where the source content exists.

Verify the following details:

  1. Ensure that the URL is entered correctly. The URL must be the same information used to run the web application.
  2. Ensure that the account information (user name, password and domain on the Transport Configuration section of the Transport tab) is correct. The account must exist in the source instance and must be active. This account is no different than any other user account used to log into the web application. You can verify the validity of the account by attempting to log into the web application using this account information.
  3. Ensure that the account has permission to run the report. After you have logged into the web application using the account (see step 2), find the saved report to ensure that this account has access to it.
  4. If a proxy server is used, ensure that the proxy information is correct.

10904

Error

The Data Feed Manager is using a Database Query transporter and is unable to connect to the source location. The source location is typically a database but can be any source supported by the specified providers.

Possible causes:

A connection string consists of a series of keyword-value pairs separated by semi-colons. An equal sign connects each keyword-value pair.

Example:

“Server=localhost;Database=BookerT;User Id=me;Password=p@ssw0rd”

In this connection string the keywords are Server, Database, User Id, and Password. The message indicates that the specified provider does not recognize 1 or more keywords in the connection string.

Keywords are specific to provider types. The keywords used by the Odbc data provider may be different from the keywords used by the SQL Server data provider.

Ensure the keywords specified in the connection string are not misspelled and they are valid for the specified Provider.

10905

Error

The data feed failed while attempting to run the query statement specified in the Database Configuration section of the Transport tab for a Database Query transporter type.

Possible causes:

  • The values of the connection string are invalid (see Message ID 10904 for further explanation of the parts that make up a connection string).
  • The query statement is invalid.

A common problem occurs when you include multiple commands in a query statement. Data feed supports only single commands for the query statement.

  1. Ensure that the values of the connection string are valid.
  2. Verify that the Query statement is correct and contains only 1 command.

10906

Error

The data feed was unable to download the specified file from the FTP server.

Possible cause:

There are several causes to this issue. A more specific error is stored in the Payload of the message which could help pinpoint the problem.

  1. Ensure that the fully-qualified URL, user name and password in the Transport Configuration section are correct.
  2. Ensure that the job servers have access to the FTP site.
  3. Ensure that the proxy settings are correct.

10907

Error

The data feed was unable to download the specified file from the HTTP server.

Possible causes:

There are several causes to this issue. A more specific error is stored in the Payload of the message which could help pinpoint the problem.

  1. Ensure that the information in the Data Request URI and Logon Properties sections is correct.
  2. Ensure that the job servers have access to the HTTP site.
  3. Ensure that the Proxy settings are correct.

10908

Error

The file specified in the path parameter was not found.

Possible causes:

  • The file specified in the path either does not exist.
  • The data feed job does not have access to the file location.

  1. Ensure that the file path and name in the path of the Transport Configuration section is correct.
  2. Verify that the file job servers have access to the file location.

10909
(Error)

Error

The data feed is unable to locate the specified Exchange folder.

Possible cause:

The folder does not exist for the specified Exchange user.

Ensure that the folder name is correct.

10910

Error

The data feed is unable to connect to the specified Exchange server.

Possible causes:

  • The mail server value is not correct.
  • The user name and password are not correct.
  • The job servers do not have access to the Exchange server.

  1. Ensure that the information in the Transport Configuration section of the Transport tab is correct.
  2. Ensure that the job servers have access to the Exchange server. To determine if the job servers have access, open a browser on the server and enter the following address:

https://<myexchangeserver>/ews/Exchange.asmx.

10112

Warning

When configured to update content, the data feed job searches each record in the target application using the key defined in the Key Field Definition tab. Most often when the job search returns more than 1 record, it indicates a problem with the content or with the defined search keys. After each search, the data feed checks the number of records returned. If that number exceeds the defined limit, this message is written to the log. The default value for this limit is 10, but the number can be changed in the ArcherTech.JobFramework.Job.exe.config file (located in the folder in which you installed the services) by adding a key in the <appSettings> node called “MaximumExpectedResultSet”.

Example:

<appSettings>

<add key="MaximumExpectedResultSet" value=number of records/>

</appSettings>

The key lookup is returning more content records than expected. If the extra records are unexpected, either the key is incorrect or the content within the target application that makes up the key value is not as unique as expected.

10996

Warning

When a failure occurs attempting to access an external resource, such as a file system or database, the process waits for a specific time period (5 seconds by default) and then retries the command. This message is generated anytime a failure occurs and the command is retried.

Possible causes:

  • Inadequate hardware or the improper configuration of the hardware resource allocation. For example, data feeds can put a significant load on the database server. If the database server is unable to handle the load, connection failures can occur.
  • Usually this problem corrects itself on a subsequent invocation of the command. If the problem does not correct itself after a specified number of attempts (10 by default), then log message 10997 generates. Detailed information about the specific problem appears in the Payload of the log entry.

If you want to reduce or eliminate these types of failures, use the information in the Payload to help identify where to focus the hardware upgrades or resource allocation changes.

10997

Critical

When a failure occurs attempting to access an external resource, such as a file system or database, the process waits a specific time period (5 seconds by default) and then retries the command. The retry occurs a specified number of times (10 by default) before the process fails. This message is generated on the last failure of the command.

Possible cause:

Because this message generates after several attempts of the command, it usually indicates a severe failure of the hardware. You can find more detailed information about the specific error in the Payload of the log entry.

Ensure that you have proper hardware capabilities and that the configuration is correct.

10998

Critical

On the very last step, the data feed job checks the status to ensure that it shows a completion status (either failed or success). If this status is any other value, this message generates. When this failure occurs, some manual intervention may be necessary before the data feed job is able to run again.

Possible cause:

The process was unable to make a connection to the database in order to update the status. This error can occur because of a database server failure.

Rerun the data feed job. If the same failure occurs repeatedly, contact Archer Technical Support.

10999

Critical

An unanticipated and therefore unhandled failure has occurred.

Possible cause:

Unknown, because it is an unanticipated failure.

Contact Archer Technical Support.

Informational logging messages

The following table includes descriptions of informational logging messages.

Message ID

Description

10000

A data feed job has started.

10001

The data feed has completed.

10002

The data feed has failed.

10003

The data feed is currently set to inactive.

On the Data Feed Manager page of the Archer Platform application, do 1 of the following:

  • On the General tab, in the General Information section, set the data feed to Active.
  • On the Schedule tab, in the Recurrences section, if you want the data feed to remain inactive, but you also want to stop this message from being logged, set the Start Date in the automatic schedule for the data feed to a date in the far future.

10100

The transporter defined in the data feed has started retrieving the source file.

10101

The transporter defined in the data feed has completed.

10102

The XML transformation process has started.

This message generates when a transform has been specified on the Navigation tab on the Data Feed Manager page of the Platform application.

10103

The XML transformation process has completed.

This message generates when a Transform has been specified on the Navigation tab on the Data Feed Manager page of the Platform application.

10104

The ZIP file extraction process has started.

When the source is a ZIP file, a secondary file extraction process runs after the specified transporter type has obtained the source file.

10105

The ZIP file extraction process has completed.

10106

When the archive option (Data Map | Update | Archive) is set to Delete or Set Value, a process runs that retrieves all the existing content IDs before content is saved. The amount of time the process runs depends on the number of content records. Log entries indicate the duration of the process.

10107

The retrieval of the content IDs for the archive process has completed.

10108

The process that saves the content to the target application has started.

10109

The process that saves the content to the target application has completed.

10110

The archive process that runs after all content is processed from the source file has started.

10111

The archive process that runs after all content is processed from the source file has completed.

11000

The job engine service has started.

11001

The job engine has stopped.

11002

A job started. The Job Engine logs this message just before the job starts. Additional logging may occur within the job itself.

The Payload of the message contains the unique identifier jobUniqueId for each job type, which enables you to monitor the start and completion of specific job types.

11003

A job started. The Job Engine logs this message after the job completes. Additional logging may occur within the job itself.